I'm going over various aspects of my 1st CCIE lab and one area that's part of the blue-print deals with PPPoE. In this posting I'm showing you a problem that I discovered while building out my lab. I'm confused over it , beacuse I can't figure it out and with fixing the issues.
1st here's my layout done in GNS3 with 2x3700s
We have R1 and R2
R1 = PPPoE server
R2= PPPoE client
R1 cfg
Building configuration...
Current configuration : 1130 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username ken password 0 ccie
!
!
!
!
bba-group pppoe global
virtual-template 1
!
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface Loopback18
ip address 10.18.0.1 255.255.255.0
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.0
duplex auto
speed auto
pppoe enable group global
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Virtual-Template1
mtu 1492
ip unnumbered Loopback0
ip rip send version 2
ip rip receive version 2
peer default ip address pool pppoe1
ppp authentication pap chap
!
router rip
version 2
network 10.0.0.0
no auto-summary
!
ip local pool pppoe1 10.10.10.10 10.10.10.20
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
R2 config
Current configuration : 1144 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username r1 password 0 r1cisco
!
!
!
!
!
interface Loopback17
ip address 10.17.0.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
ip tcp adjust-mss 1452
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip rip send version 2
ip rip receive version 2
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap chap callin
ppp chap hostname ken
ppp chap password 0 ccie
ppp pap sent-username ken password 0 ccie
!
router rip
version 2
network 10.0.0.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
Okay here's the problem, R1 is sending via RIPv2 to R2 and the likewise for R2 to R1, but rip announcements are not showing up in r2 table
debug rip events shows the following;
r1
*Mar 1 00:44:49.391: RIP: sending v2 update to 224.0.0.9 via Loopback18 (10.18.0.1)
*Mar 1 00:44:49.391: RIP: Update contains 3 routes
*Mar 1 00:44:49.391: RIP: Update queued
*Mar 1 00:44:49.391: RIP: Update sent via Loopback18
*Mar 1 00:44:49.391: RIP: ignored v2 packet from 10.18.0.1 (sourced from one of our addresses)
*Mar 1 00:44:52.379: RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.10.10.1)
*Mar 1 00:44:52.379: RIP: Update contains 3 routes
*Mar 1 00:44:52.379: RIP: Update queued
*Mar 1 00:44:52.379: RIP: Update sent via Loopback0
*Mar 1 00:44:52.379: RIP: ignored v2 packet from 10.10.10.1 (sourced from one of our addresses)
*Mar 1 00:44:58.715: RIP: received v2 update from 10.10.10.11 on Virtual-Access1.1
*Mar 1 00:44:58.715: RIP: Update contains 1 routes
*Mar 1 00:45:02.203: RIP: sending v2 update to 224.0.0.9 via Virtual-Access1.1 (10.10.10.1)
*Mar 1 00:45:02.203: RIP: Update contains 2 routes
*Mar 1 00:45:02.203: RIP: Update queued
*Mar 1 00:45:02.203: RIP: Update sent via Virtual-Access1.1
*Mar 1 00:45:15.059: RIP: sending v2 update to 224.0.0.9 via Loopback18 (10.18.0.1)
*Mar 1 00:45:15.059: RIP: Update contains 3 routes
*Mar 1 00:45:15.059: RIP: Update queued
*Mar 1 00:45:15.059: RIP: Update sent via Loopback18
*Mar 1 00:45:15.059: RIP: ignored v2 packet from 10.18.0.1 (sourced from one of our addresses)
*Mar 1 00:45:18.767: RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.10.10.1)
*Mar 1 00:45:18.767: RIP: Update contains 3 routes
*Mar 1 00:45:18.767: RIP: Update queued
*Mar 1 00:45:18.767: RIP: Update sent via Loopback0
*Mar 1 00:45:18.767: RIP: ignored v2 packet from 10.10.10.1 (sourced from one of our addresses)
*Mar 1 00:45:27.851: RIP: received v2 update from 10.10.10.11 on Virtual-Access1.1
*Mar 1 00:45:27.851: RIP: Update contains 1 routes
*Mar 1 00:45:28.279: RIP: sending v2 update to 224.0.0.9 via Virtual-Access1.1 (10.10.10.1)
*Mar 1 00:45:28.279: RIP: Update contains 2 routes
*Mar 1 00:45:28.279: RIP: Update queued
*Mar 1 00:45:28.279: RIP: Update sent via Virtual-Access1.1
*Mar 1 00:45:44.667: RIP: sending v2 update to 224.0.0.9 via Loopback18 (10.18.0.1)
*Mar 1 00:45:44.667: RIP: Update contains 3 routes
*Mar 1 00:45:44.667: RIP: Update queued
*Mar 1 00:45:44.667: RIP: Update sent via Loopback18
*Mar 1 00:45:44.667: RIP: ignored v2 packet from 10.18.0.1 (sourced from one of our addresses)
*Mar 1 00:45:45.591: RIP: sending v2 update to 224.0.0.9 via Loopback0 (10.10.10.1)
*Mar 1 00:45:45.591: RIP: Update contains 3 routes
*Mar 1 00:45:45.591: RIP: Update queued
*Mar 1 00:45:45.591: RIP: Update sent via Loopback0
*Mar 1 00:45:45.591: RIP: ignored v2 packet from 10.10.10.1 (sourced from one of our addresses)
*Mar 1 00:45:54.251: RIP: sending v2 update to 224.0.0.9 via Virtual-Access1.1 (10.10.10.1)
*Mar 1 00:45:54.251: RIP: Update contains 2 routes
*Mar 1 00:45:54.251: RIP: Update queued
*Mar 1 00:45:54.251: RIP: Update sent via Virtual-Access1.1
r2 debug
r2#
*Mar 1 00:43:08.707: RIP: sending v2 update to 224.0.0.9 via Loopback17 (10.17.0.1)
*Mar 1 00:43:08.707: RIP: Update contains 2 routes
*Mar 1 00:43:08.707: RIP: Update queued
*Mar 1 00:43:08.707: RIP: Update sent via Loopback17
*Mar 1 00:43:08.707: RIP: ignored v2 packet from 10.17.0.1 (sourced from one of our addresses)
*Mar 1 00:43:09.971: RIP: sending v2 update to 224.0.0.9 via Dialer1 (10.10.10.11)
*Mar 1 00:43:09.971: RIP: Update contains 1 routes
*Mar 1 00:43:09.971: RIP: Update queued
*Mar 1 00:43:09.971: RIP: Update sent via Dialer1
*Mar 1 00:43:11.915: RIP: ignored v2 update from bad source 10.10.10.1 on Dialer1
*Mar 1 00:43:34.379: RIP: sending v2 update to 224.0.0.9 via Loopback17 (10.17.0.1)
*Mar 1 00:43:34.379: RIP: Update contains 2 routes
*Mar 1 00:43:34.379: RIP: Update queued
*Mar 1 00:43:34.379: RIP: Update sent via Loopback17
*Mar 1 00:43:34.379: RIP: ignored v2 packet from 10.17.0.1 (sourced from one of our addresses)
*Mar 1 00:43:36.975: RIP: sending v2 update to 224.0.0.9 via Dialer1 (10.10.10.11)
*Mar 1 00:43:36.975: RIP: Update contains 1 routes
*Mar 1 00:43:36.975: RIP: Update queued
*Mar 1 00:43:36.975: RIP: Update sent via Dialer1
*Mar 1 00:43:40.831: RIP: ignored v2 update from bad source 10.10.10.1 on Dialer1
*Mar 1 00:44:02.347: RIP: sending v2 update to 224.0.0.9 via Loopback17 (10.17.0.1)
*Mar 1 00:44:02.347: RIP: Update contains 2 routes
*Mar 1 00:44:02.347: RIP: Update queued
*Mar 1 00:44:02.347: RIP: Update sent via Loopback17
*Mar 1 00:44:02.347: RIP: ignored v2 packet from 10.17.0.1 (sourced from one of our addresses)
*Mar 1 00:44:03.599: RIP: sending v2 update to 224.0.0.9 via Dialer1 (10.10.10.11)
*Mar 1 00:44:03.599: RIP: Update contains 1 routes
*Mar 1 00:44:03.599: RIP: Update queued
*Mar 1 00:44:03.599: RIP: Update sent via Dialer1
*Mar 1 00:44:08.979: RIP: ignored v2 update from bad source 10.10.10.1 on Dialer1
*Mar 1 00:44:28.615: RIP: sending v2 update to 224.0.0.9 via Loopback17 (10.17.0.1)
*Mar 1 00:44:28.615: RIP: Update contains 2 routes
*Mar 1 00:44:28.615: RIP: Update queued
*Mar 1 00:44:28.615: RIP: Update sent via Loopback17
*Mar 1 00:44:28.615: RIP: ignored v2 packet from 10.17.0.1 (sourced from one of our addresses)
*Mar 1 00:44:31.763: RIP: sending v2 update to 224.0.0.9 via Dialer1 (10.10.10.11)
*Mar 1 00:44:31.763: RIP: Update contains 1 routes
*Mar 1 00:44:31.763: RIP: Update queued
*Mar 1 00:44:31.767: RIP: Update sent via Dialer1
*Mar 1 00:44:35.435: RIP: ignored v2 update from bad source 10.10.10.1 on Dialer1
*Mar 1 00:44:58.047: RIP: sending v2 update to 224.0.0.9 via Loopback17 (10.17.0.1)
*Mar 1 00:44:58.047: RIP: Update contains 2 routes
*Mar 1 00:44:58.047: RIP: Update queued
*Mar 1 00:44:58.047: RIP: Update sent via Loopback17
*Mar 1 00:44:58.047: RIP: ignored v2 packet from 10.17.0.1 (sourced from one of our addresses)
*Mar 1 00:44:58.735: RIP: sending v2 update to 224.0.0.9 via Dialer1 (10.10.10.11)
*Mar 1 00:44:58.735: RIP: Update contains 1 routes
*Mar 1 00:44:58.735: RIP: Update queued
*Mar 1 00:44:58.735: RIP: Update sent via Dialer1
*Mar 1 00:45:02.227: RIP: ignored v2 update from bad source 10.10.10.1 on Dialer1
*Mar 1 00:45:25.555: RIP: sending v2 update to 224.0.0.9 via Loopback17 (10.17.0.1)
*Mar 1 00:45:25.555: RIP: Update contains 2 routes
*Mar 1 00:45:25.555: RIP: Update queued
*Mar 1 00:45:25.555: RIP: Update sent via Loopback17
*Mar 1 00:45:25.555: RIP: ignored v2 packet from 10.17.0.1 (sourced from one of our addresses)
*Mar 1 00:45:27.867: RIP: sending v2 update to 224.0.0.9 via Dialer1 (10.10.10.11)
*Mar 1 00:45:27.867: RIP: Update contains 1 routes
*Mar 1 00:45:27.867: RIP: Update queued
*Mar 1 00:45:27.867: RIP: Update sent via Dialer1
*Mar 1 00:45:28.303: RIP: ignored v2 update from bad source 10.10.10.1 on Dialer1
*Mar 1 00:45:52.999: RIP: sending v2 update to 224.0.0.9 via Loopback17 (10.17.0.1)
*Mar 1 00:45:52.999: RIP: Update contains 2 routes
*Mar 1 00:45:52.999: RIP: Update queued
*Mar 1 00:45:52.999: RIP: Update sent via Loopback17
*Mar 1 00:45:52.999: RIP: ignored v2 packet from 10.17.0.1 (sourced from one of our addresses)
*Mar 1 00:45:54.271: RIP: ignored v2 update from bad source 10.10.10.1 on Dialer1
*Mar 1 00:45:56.947: RIP: sending v2 update to 224.0.0.9 via Dialer1 (10.10.10.11)
*Mar 1 00:45:56.947: RIP: Update contains 1 routes
*Mar 1 00:45:56.947: RIP: Update queued
*Mar 1 00:45:56.947: RIP: Update sent via Dialer1
*Mar 1 00:46:20.507: RIP: sending v2 update to 224.0.0.9 via Loopback17 (10.17.0.1)
*Mar 1 00:46:20.507: RIP: Update contains 2 routes
*Mar 1 00:46:20.507: RIP: Update queued
*Mar 1 00:46:20.507: RIP: Update sent via Loopback17
Route tables;
1st R2s;
r2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
20.0.0.0/32 is subnetted, 1 subnets
C 20.0.0.1 is directly connected, Dialer1
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.10.10/32 is directly connected, Dialer1
C 10.17.0.0/24 is directly connected, Loopback17
S* 0.0.0.0/0 is directly connected, Dialer1
r2#
Now r1
r1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.10.10.11/32 is directly connected, Virtual-Access1.1
C 10.10.10.1/32 is directly connected, Loopback0
C 10.18.0.0/24 is directly connected, Loopback18
R 10.17.0.0/24 [120/1] via 10.10.10.11, 00:00:18, Virtual-Access1.1
Okay and finally show ip protocols;
r1;
r1#show ip proto
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 23 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
Virtual-Access1.1 2 2
Virtual-Template1 2 2
Loopback0 2 2
Loopback18 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
Routing Information Sources:
Gateway Distance Last Update
10.10.10.10 120 00:00:16
Distance: (default is 120)
and r2;
r2#show ip proto
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 21 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
Dialer1 2 2
Loopback17 1 1 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 120)
I have no immediate fix NOW, but I will follow-up later unless some other finds out the issues and reply to my blog.
Ken Felix
Freelance Network & Security Specialist
kfelix at hyperfeed dot c-o-m
No comments:
Post a Comment